Patch/New Release

Jul 29, 2009 at 3:21 AM

Hi Bill,

Any idea if patch will be released?  Thx.

Coordinator
Jul 29, 2009 at 5:11 PM

I don't have anything currently planned. Is there something not working that you need fixed?

Jul 30, 2009 at 1:18 AM
Edited Jul 30, 2009 at 1:46 AM

Hi Bill,

Thanks for prompt reply.  Actually I have the same Url problem that other folks have and I thought it is caused by the extra question mark at the end of the Url string.  Can I send you the project so that you can see where the problem comes from?

 

Regards,

SLICan

Coordinator
Jul 30, 2009 at 2:34 AM

Sure, send it over. It sounds like any easy fix....

Jul 30, 2009 at 2:44 AM
Edited Jul 30, 2009 at 4:44 AM

I just emailed to you.  Thanks.

Jul 30, 2009 at 3:38 PM

Bill,

FYI, I tested both version 2.0 and 2.5.  V2.0 works provided every page is in root, if there's one page in a sub-folder then the path will get screwed up as soon as that page is selected.  For v2.5,  so far I can't fnd a scenario that works.

Regards,

SLICan

Aug 4, 2009 at 2:42 PM
wdavidsen wrote:

Sure, send it over. It sounds like any easy fix....

 Hi Bill, just wonder if you get a chance to look at the project I emailed you.  Thx.

Coordinator
Aug 5, 2009 at 2:24 AM

I’ve set it up and have it running. Can you give me steps to recreate the error?


From: SLICan [mailto:notifications@codeplex.com]
Sent: Tuesday, August 04, 2009 10:43 AM
To: wdavidsen@yahoo.com
Subject: Re: Patch/New Release [MultiMenu:63827]

From: SLICan

wdavidsen wrote:

Sure, send it over. It sounds like any easy fix....

Hi Bill, just wonder if you get a chance to look at the project I emailed you. Thx.

Read the full discussion online.

To add a post to this discussion, reply to this email (MultiMenu@discussions.codeplex.com)

To start a new discussion for this project, email MultiMenu@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Aug 5, 2009 at 4:51 AM

Thanks again for reply.  I accidentally deleted the database and project I sent you but if you look at the records in MenuItem table you should see the options that were set up to be clickable (should be first option and second option on menu).  SImply select first option and select second opption (or the other way around), theoretically both pages should be reachable but the second page is not.  Please let me know if you cannnot simulate the problem, I'll re-send you another copy.

Thanks a million.

Coordinator
Aug 7, 2009 at 8:40 PM

The file "abc.aspx" that is configured in the database was not in the Web you provided. But, I was able to add it myself and I think I know what your problem is. The Urls in your database are relative and cannot be used with your multi-directory web. Either put all your Web pages in one directory and use only the page file names in the database, or make the Urls in the database virtual by prepending '/ERPv2/Access/' to each url.

Aug 7, 2009 at 9:51 PM
wdavidsen wrote:

The file "abc.aspx" that is configured in the database was not in the Web you provided. But, I was able to add it myself and I think I know what your problem is. The Urls in your database are relative and cannot be used with your multi-directory web. Either put all your Web pages in one directory and use only the page file names in the database, or make the Urls in the database virtual by prepending '/ERPv2/Access/' to each url.

 Thanks Bill.

Just to clarify my understanding which is under the current version multi-folder is not possible yet.  Will you be planning to enhance it?

Coordinator
Aug 7, 2009 at 11:02 PM

Its possible, you just have to have put the full urls in the database. You could also modify the stored procedure to accept the root portion of the url from your website and prepend it to each page file name within the procedure. You would want to do somthing like this if the web root is not known until runtime or if you want to change all the roots easily from one configuration point. At this time I don't have any plans to upgrade this control since there are other controls I am working on and just don't have the time to give.

Aug 9, 2009 at 5:47 PM

Hi Bill,

If you try the full Url case, yes it works but only for the 1st attempt and it will fail on the attempt to access 2nd option in another folder.  You can re-crearte the case as follows:

  1. Create two folders namely "folder1" and "folder2" in root
  2. Create page1.aspx in folder1 and page2.aspx in folder2 respectively
  3. Create two new reocrds in menuitem table to access the newly crerate pages with full url
  4. Access page1.aspx from menu, if works fine
  5. Now access pages2.aspx, it fails and you should see the path generated by the control is incorrect.

I hope this gives sufficient information to reproduce the situation.  Thanks.

Coordinator
Aug 9, 2009 at 6:50 PM

I followed your steps and everything looked good. You may be dealing with cached XML because by defaul the control witll cache the XML. Try killing your developer server instance and starting again. I'll send you what I have setup so you can take a look.

Aug 9, 2009 at 7:13 PM

Hi Bill,

Thanks for promtp reply and sorry for keeping bothering you.  Definitely I will trying your set up and get back to you.  Have a nice weekend.

Regards,

SLICan

Aug 9, 2009 at 8:33 PM
wdavidsen wrote:

I followed your steps and everything looked good. You may be dealing with cached XML because by defaul the control witll cache the XML. Try killing your developer server instance and starting again. I'll send you what I have setup so you can take a look.

 Hi Bill,

Unfortunately I can't get it work from my end.  I just emailed you again the project, mdb and screenshots, I hope you can kindly have it reviewed again at your convenience.  Appreciated.

Aug 14, 2009 at 3:12 AM
wdavidsen wrote:

I followed your steps and everything looked good. You may be dealing with cached XML because by defaul the control witll cache the XML. Try killing your developer server instance and starting again. I'll send you what I have setup so you can take a look.

 Hello Bill,

Just wondering if you will be re-considering to review the sample app I re-sent you earlier.  Just simply set it up and run, You should be able to see the problem.    Thanks.

Coordinator
Aug 18, 2009 at 9:01 PM

I looked at the new database and you still have relative URLs entered--like I said above, they will not work.  

CHANGE: ../access/folder1/page1.aspx  TO: /ERPv2/access/folder1/page1.aspx

CHANGE: ../access/folder2/page2.aspx  TO: /ERPv2/access/folder1/page2.aspx

For more information on relative and absolute URLs see: http://www.webdevelopersnotes.com/design/relative_and_absolute_urls.php3

 

Aug 19, 2009 at 1:28 AM
wdavidsen wrote:

I looked at the new database and you still have relative URLs entered--like I said above, they will not work.  

CHANGE: ../access/folder1/page1.aspx  TO: /ERPv2/access/folder1/page1.aspx

CHANGE: ../access/folder2/page2.aspx  TO: /ERPv2/access/folder1/page2.aspx

For more information on relative and absolute URLs see: http://www.webdevelopersnotes.com/design/relative_and_absolute_urls.php3

 

Hello Bill,

Now I get it.  My sincere apology for keep bugging you.  It works.  Thanks a lot.