Menu expanding overlap

Nov 22, 2008 at 1:48 AM
Hello,

I am trying to horizontal menu example, however when I hover over items in a menu that are to expand to the right or the left they do not appear to the right or left, they just overlap the current menu.  I do not see a difference between mine and the example.  Might anybody know what I am missing?

Thanks,
Danny
Coordinator
Nov 24, 2008 at 12:50 PM
Danny, I've see that before, but can't remember what the solution was. Can you post your XML here for me to look at? -Bill
Nov 26, 2008 at 1:33 AM
Hi Bill,

Here is my source code:

<SCS:MultiMenu id="multiMenu1" runat="server" enableskiplink="True" imagesurlbase="/FM/controls/menu/images"
                stylesheeturl="/FM/controls/menu/menu.css" xmlpath="/FM/controls/menu/test.xml"
                enablekeyboard="True" enabletooltips="True" EnableTopMenuMarkers="true"
                wordwrap="False" Width="-1">
                <LevelGroupClasses>
                    <SCS:groupclass normal="TopMenuGroup"></SCS:groupclass>
                    <SCS:groupclass normal="SubMenuGroup"></SCS:groupclass>
                </LevelGroupClasses>
                <LevelLeftMenuMarkers>
                    <SCS:MenuMarker url="arrow_d.gif" height="13" width="15"></SCS:MenuMarker>
                    <SCS:MenuMarker url="arrow_l.gif" height="13" width="15"></SCS:MenuMarker>
                </LevelLeftMenuMarkers>
                <levelitemclasses>
                    <SCS:ItemClass disabled="MenuItemDisabled" over="MenuItemOver" normal="MenuItem" selectedover="MenuItemSelected"
                        selected="MenuItemSelected"></SCS:ItemClass>
                </levelitemclasses>
                <LevelRightMenuMarkers>
                    <SCS:MenuMarker url="arrow_d.gif" height="13" width="15"></SCS:MenuMarker>
                    <SCS:MenuMarker url="arrow_r.gif" height="13" width="15"></SCS:MenuMarker>
                </LevelRightMenuMarkers>
            </SCS:MultiMenu>

Here is the contents of test.xml which is what xmlpath resolves to:

<MenuGroup>
  <MenuItem Width="80" Text="Students">
    <MenuGroup Width="110" ExpandDirection="Right" HorizontalOffset="2" VerticalOffset="-2">
      <MenuItem Text="Add Student"  ToolTip="Add FEDS student." />
      <MenuItem Text="Student Search" ToolTip="Search FEDS students."/>
    </MenuGroup>
  </MenuItem>
  <MenuItem IsDivider="True" CssClass=" " Image="divider_v.gif" />
  <MenuItem Width="80" Text="Classes">
    <MenuGroup Width="110" ExpandDirection="Right" HorizontalOffset="2" VerticalOffset="-2">
      <MenuItem Text="Add/Edit Classes"  ToolTip="Add or edit FEDS classes." />
      <MenuItem Text="Class Search" ToolTip="Search FEDS classes.">
        <MenuGroup Width="150" ExpandDirection="Right">
          <MenuItem Text="Boca" />
          <MenuItem Text="Palm Beach" Url="test.aspx" />
        </MenuGroup>
      </MenuItem>
    </MenuGroup>
  </MenuItem>
</MenuGroup>

Thanks,
Danny






Coordinator
Dec 1, 2008 at 3:14 PM
Danny, your markup and XML look good and I am unable to recreate your problem. Can you also send me your CSS file, or better yet send me all the pieces working together in one project. Also, what DOCTYPE are you using? Email me at wdavidsen[at]yahoo.com.
Dec 17, 2008 at 11:42 PM
Sure thing Bill.  E-mail sent, thanks for the help.
-Danny
Coordinator
Dec 18, 2008 at 3:19 PM
Hi Danny-
I looked at you code and the problem is that the DOCTYPE specified is not supported (at this time) by the menu. Use this instead: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >.

-Bill

Coordinator
Mar 29, 2010 at 8:47 PM

Just wanted to let you know that the menu now works with the XHTML doctypes.